Issue:
Showing data for a device in DCE that is not being polled or not available.
Product Line:
Data Center Expert (DCE)
Environment:
DCE any version
Cause:
In some cases, data may show from one brand or model of device but not another. Customers may like to be able to provide this data for the devices not showing these values.
Resolution:
In the case of an SNMP device, for instance, run an SNMPwalk of the device to see if the information is available. If it is, potentially getting an updated DDF (Device Definition File) for your device would provide the information you need. If it is not available and a changing value, that is something you may want to speak with the vendor about making available.
For a modbus device, check your modbus register map. If it is not available, you need to again contact the vendor. If it is available but not showing, your DDF may need to be edited.
DDFs are found here:
https://ddf.ecostruxureit.com/
In the case of a static piece of data such as a location or device name, if the data is not available through the device when polling it, you can use DCE's "Custom Property" function. A custom property can be assigned to any or all devices and can provide a piece of static information about the device. A custom property key can be used as a column in DCE (see DCE help for details or search for knowledge base document FA299535 or FA386978) and will show in the interface. The values associated with this key however can not be used to fill existing columns for actual device data though. For instance, if devices provide a location field but your specific device does not your new "location" custom property key and location can not emerge with the existing location column. If you must have all the data in the same column, you will need to provide a custom property to all devices.