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How To: Configuring an APC Network Management Card with popular email services such as Gmail, Yahoo!, Office 365, and Hotmail/Outlook.com
Issue
Popular email services such as Gmail, Yahoo!, Office 365, and Hotmail/Outlook.com are not working with an APC Network Management Card-enabled device or need to be set up for the first time; local mail server is not available to relay mail to an external service

Product Line
  • Web/SNMP Card - AP9606
Devices with an embedded Web/SNMP Card include (but are not limited to): Environmental Monitoring Unit 1 (AP9312TH)
  • Network Management Card 1 (NMC1) - AP9617, AP9618, AP9619
Devices with an embedded Network Management Card 1 include (but are not limited to): Metered/Switched Rack PDUs (AP78XX, AP79XX), Rack Automatic Transfer Switches (AP77XX, Environmental Monitoring Units (AP9320, AP9340, NetBotz 200)
  • Network Management Card 2 (NMC2) - AP9630/AP9630CH, AP9631/AP9631CH, AP9635/AP9635CH
Devices with an embedded Network Management Card 2 include (but are not limited to): 2G Metered/Switched Rack PDUs (AP86XX, AP88XX, AP89XX), Certain Audio/Video Network Management Enabled products.
  • Network Management Card 3 (NMC3) – AP9640, AP9641
Environment
  • Applicable to AOS v 3.7.X, 5.1.X and v6.0.X as noted
  • No local email server on the same domain is available to relay to an external email account

Cause
Instructions are provided for reference and/or verification to ensure the email notification will be sent using external mail services.

Resolution


Please refer to the steps/requirements below in order to have a Network Management Card device send email to an external email service such as Gmail, Yahoo! or Hotmail.

Using Firmware Version v3.7.X, 5.1.X (NMC1/NMC2)

NOTE: These steps were validated on AOS v5.1.7 with AP9630 but would be the same for v3.7.X. Users with AOS v6.0.X and higher can utilize the custom option outlined below.

1.) Within the Web UI, navigate to Administration > Network > DNS > Servers, ensure your DNS server IP addresses are entered properly.
1.a) Recommended: Try a DNS test using the configured DNS servers to verify the Network Management Card is able to resolve the domain you are sending to i.e. www.gmail.com

2.) Navigate to Administration > Notification > Email > Server. Configure the From Address appropriately. Example: joesmith@gmail.com
For Hotmail, it is recommended you change the From Address to have the same source domain, meaning if your ISP is Comcast and their domain is comcast.net, the from address must be address@comcast.net. Click Apply when complete. This may be required for other mail services as well.

3.) Navigate to Administration > Notification > Email > Recipients. Click Add Recipient and enter in your email address. Configure the other email options as you'd like, ensuring Email Generation is enabled. For v5.1.X and higher, please note you do not need to enter in any authentication credentials. Click Apply.

4.) Navigate to Administration > Notification > Email > Test. Choose the correct recipient from the dropdown list and click Apply to issue an email test. Allow 1-2 minutes and check your email inbox/SPAM folder for the test email.

Troubleshooting Notes for using v3.7.X, v5.1.X:
  • If the instructions above do not work, please ensure that TCP port 25 is open. Many ISP's block this port for security reasons, especially for home users (versus business users). The original/legacy email ports have been in use since the inception of email and have limited or no security features. As a result, many ISP's block port 25 since it has been used for the transmission of spam and malware from infected computers for nearly a decade. Another option may be to use a different port your provider supports but these ports generally will require SSL SMTP authentication which v3.7.X and v5.1.X do not support. If that is the case, you'll need to pursue the options listed for NMC2 firmware version v6.0.X below. NMC1 SKUs will never be able to support SSL authentication.
  • Please also check that your outgoing From Address matches your ISP's domain, a DNS test works, and that the test email is not in your spam folder. If it is, you will need to authorize your Network Management Card as a legitimate sender.
  • Keep in mind, if you are using multiple recipients including any that are using the local mail server, changing your From Address to match your ISP's domain may cause your local mail server to reject the address.
Using Firmware Version v6.0.X and higher (NMC2), and NMC3 devices

1.)  Within the Web UI, navigate to Configuration > Network > DNS > Configuration and ensure your DNS server IP addresses are entered properly.
1.a) Recommended: Try a DNS test using the configured DNS servers to verify the Network Management Card is able to resolve the domain you are sending to i.e. www.gmail.com

2.) Navigate to Configuration > Notification > Email > Recipients. Under Email Recipient, enable Email Generation and enter your email address. Example: joesmith@gmail.com

3.) Within the same screen, specify the Server option as Custom. Upon doing so, Custom Email Server Settings will become available in the section below. These settings should be readily available by checking with your email provider. You'll need these (SMTP server, SMTP authentication mode, SMTP port, etc.) for the recipient configuration to be successful. If any one of the settings you input is incorrect, this will cause email to fail.

NOTE:For Hotmail/Outlook.com, it is recommended you change the From Address to have the same source domain, meaning if your ISP is Comcast and their domain is comcast.net, the from address must be address@comcast.net. This may be required for other mail services as well.

NOTE:For Gmail, you may need to modify an account setting to allow the NMC to send email through your Gmail account(s). Please refer to this Google/Gmail Knowledge Base for more information regarding a security setting and setting it to ON for your APC NMC device to be allowed access to your Gmail account. If using 2-step authentication with your Gmail account, an app password would need to be configured to allow the NMC to send emails, please refer to this Google Knowledge Base on configuring app passwords.

4.) Under Advanced, ensure you specify SMTP authentication encryption, if required, as well as the appropriate port number (both provided by your email provider). If you are unsure if your provider requires authentication encryption, choose If Supported. Click Apply when complete. You can also toggle between the different modes and perform an email test after changing it.

5.) Navigate to Configuration > Notification > Email > Test and choose the appropriate recipient to test. Click Apply to issue an email test. Allow 1-2 minutes and check your email inbox/SPAM folder for the test email. Review the Last Test Result and Last Server Response messages and re-configure your settings if you need to.

NOTE:If this does not work, please ensure that port 25 is open (or whatever port your email provider uses), verify you've obtained the correct settings from your email provider, your outgoing From Address matches your ISP's domain, a DNS test works, and that the test email is not in your spam folder. If it is, you will need to authorize your Network Management Card as a legitimate sender.

Additional information:
  • The 'recipients' mail server setting works by doing a DNS lookup on the domain of the email address. The Network Management Card will look for an MX Record in order to forward the email to the recipient's mail server. The Network Management Card does this one time only per email request. If it fails, there are no retries.
  • The Network Management Card 2/3 (NMC2/NMC3) SMTP email Authentication Modes are explained below for reference. The following options are offered:
    • Ability to enable/disable authentication using a checkbox (which offers plain text/basic SMTP authentication)
    • Ability to enable disable SSL/TLS and configure advanced options including those below:
      • If supported – The NMC will begin the SMTP conversation with the EHLO command and see if SSL/TLS is a supported option on the SMTP server. If supported, the NMC will use SSL/TLS. If unsupported, the email will be sent using basic (plain text) authentication.
      • Always – The NMC will begin the SMTP conversation with the EHLO command and ensure SSL/TLS is an available option reported by the SMTP server. NOTE: Email will not be sent if authentication is not configured on the SMTP server.
      • Implicit – The NMC skips any SSL/TLS negotiations and enters immediately into a secured connection on a user specified port.
NOTE: Some providers, such as Office 365, require TLS v1.1 for SMTP SSL/TLS authentication. TLS v1.1/1.2 is supported only on firmware revision v6.5.0+. If firmware cannot be upgraded, or if this cannot be modified on the provider's end, email likely won't work and a workaround may need to be investigated for the particular situation.

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