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Received ssh2_msg_channel_success for nonexistent channel 65536" error message using SSH with PuTTy v0.63 and higher with APC Network Management Card 1 (NMC1) devices


Issue

A user may receive the following error message when using newer versions of PuTTy SSH client with NMC1 devices: "disconnected: received ssh2_msg_channel_success for nonexistent channel 65536"

Picture of putty error: "received ssh2_msg_channel_success for nonexistant channel 65536"

This may also affect versions of WinSCP and produce  similar error message upon logging in to do an SCP file transfer due to the fact that SSH and SCP code for WinSCP is based on PuTTy's.


Product Line
  • Network Management Card 1 - AP9617, AP9618, AP9619
Devices with an embedded Network Management Card 1 include (but are not limited to): Metered/Switched Rack PDUs (AP78XX, AP79XX), Rack Automatic Transfer Switches (AP77XX), Environmental Monitoring Units (AP9320, AP9340, Netbotz 200).


Environment
  • All firmware versions
  • PuTTy SSH client v0.63 and higher (will also likely affect WinSCP users)
  • Users that utilize SSH for remote command line access

Cause

This is due to some incompatibility with newer PuTTy client versions and older SSH server versions in NMC1 products, this error message is received and access is not allowed. This will also likely affect WinSCP users since WinSCP and PuTTy share similar SSH and SCP code.

Resolution

The NMC1 is a discontinued product. It is suggested that a user use an older version of the PuTTy client, if available. Otherwise, other commonly available SSH clients may work in order to access the NMC1 device via the SSH protocol.

APC Canada

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