{}

Our Brands

Search FAQs
Why does PowerChute Personal Edition hang / stall during the installation when asked to select an installation folder?

Issue:
During the installation of PowerChute Personal Edition when asked to select an installation folder after clicking the Next button the installation hangs / stalls.

Product Line:
PowerChute Personal Edition (PCPE)

Environment:
PCPE versions 3.0, 3.0.0.1, 3.0.2
Windows XP, Vista, Windows 7, 8, 10

Cause:
Incomplete removal of McAfee software
Or
corruption in Windows Management Instrumentation (WMI)
See Microsoft FAQs for information on WMI http://technet.microsoft.com/en-us/library/ee692772.aspx

Solution:

#1

If the system had McAfee software uninstalled at any time PCPE may not install properly due to an incomplete uninstall.
Go to
http://download.mcafee.com/products/licensed/cust_support_patches/MCPR.exe
download the McAfee uninstaller patch, run that, reboot the system, and then run the PCPE installer.

#2

If the issue is not due to incomplete McAfee uninstall it could be caused by corruption in the Windows Management Instrumentation (WMI).

Run these commands from the command prompt.

Click Start, Run and type CMD.EXE

Note: For Vista and Windows 7, 8, 10 you need to open Command Prompt window as an administrator. To do so, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.

For all OS:

Note: To save time and effort copy and paste the commands.
  • Net stop winmgmt (answer yes to any questions asked)
  • cd C:/Windows/system32/wbem
  • xcopy Repository Repository.old
  • rmdir /s Repository (answer yes to any questions asked)
  • Net start winmgmt

For Windows XP:
  • rundll32 wbemupgd, UpgradeRepositor

For Vista and Windows 7, 8, 10 :
  • winmgmt /salvagerepository

For all OS run these commands:
  • cd /d %windir%\system32\wbem
  • for %i in (*.dll) do RegSVR32 -s %i
  • for %i in (*.exe) do %i /RegServer
Windows Management Instrumentation Tester

After running "for %i in (*.exe) do %i /RegServer" the above pop up window will appear. Just X out / close the window.

Now reboot the system and then run the PCPE installer.

APC Belgium

Articles which might be helpful Users group

Discuss this topic with experts

Visit our Community for first-hand insights from experts and peers on this topic and more.