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Back-UPS is detected as an ""Unknown Device"" in Device Manger
Issue:
Back-UPS is detected as an ""Unknown Device"" in Device Manger
Product Line:
All APC Back-UPS UPS utilizing USB communications.
Environment:
All APC Back-UPS UPS utilizing USB communications.
Cause:
If communication between the PC and the USB compatible Back-UPS, is not working properly when the cable is first connected, an ""Unknown Device"" is detected. This problem may be the result of a weak USB receiver on the PC side. If the UPS itself is not detected when the cable is connected (i.e., its not detecting a ""Back UPS Pro 350"", the installation of APC's Power Management Extensions or Powerchute Personal Edition may fail or hang after the setup.exe file is executed.
Resolution:
1. Make sure the UPS and PC are turned on. Disconnect and reconnect the USB cable a few times until the PC detects the appropriate UPS model. Once it
does, continue on with the installation instructions. If this is not successful, go to the next step.
2. Check to see if the Human Interface Device (HID) drivers are already installed. If they are not installed, the Add New Hardware Wizard will not start
up when the USB cable is connected. If the HID drivers are installed, then continue on with the installation of APC's Power Management Extensions
software. To check to see if these drivers are installed go to Device Manager (Start - Settings - Control Panel - System - Device Manager) and look for a
device category called ""Human Interface Device"". If you then unplug the USB cable, this line item will disappear. When you reconnect the cable, the
category will reappear. This confirms that the drivers are properly installed.
3. Confirm that your PC's USB ports are enabled. Go to Device Manager (Start - Settings - Control Panel - System - Device Manager) and look at the list of installed devices.
Towards the bottom, you should see, ""Universal Serial Bus controllers"" and within that you will see, XXX ""Universal Host Controller"" and ""USB Root Hub"".
If Device Manager does not list these items, then your PC is not properly configured to support USB ports. Consult your PC manufacturer for help on this issue.
4. If you are connected through a USB Hub, try connecting the supplied UPS's USB cable directly to a USB port on the PC itself.
5. If other USB devices are connected, try removing those other devices before connecting our USB cable.
6. If possible, try the same installation on another PC or with another UPS.
7. Reboot your PC. After reboot, did your PC recognize the UPS or are you still receiving the initial message of ""Please check that the USB cable between your battery backup and PC is properly connected”? If so, there are a few parameters of your PC’s BIOS that need to be changed in order for your PC to recognize the USB device as an APC UPS after each boot. These changes are as follows:
Advanced Power Management – Needs to be disabled
USB Legacy Device – Needs to be enabled
Note: An APC representative cannot make changes or assist customers in making changes to the BIOS, as it is a liability to APC. The BIOS of your PC is both manufacturer and model specific. Consultation of the Original Equipment Manufacturer is advised in making these changes.
8. If none of the above steps work, please contact APC's Technical Support in the United States and Canada via E-Support at www.apcc/support/contact or via
telephone at 800-800-4272. For support outside of North America, please refer to APC's worldwide contact page at www.apcc.com/contact/#worldwide
Note for Back UPS PRO 350U or 500U users: Compaq Presario Series 5000/5100/5200 computers using non-Intel chip sets have demonstrated unpredictable USB performance with some USB peripherals. APC has developed a special USB connector for these computers which will significantly improve the reliability of USB communications. APC strongly recommends the use of this special connector with Compaq 5000/5100/5200 series computers.
To get your special USB connector shipped to you at no charge, visit the Web at http://promo.apcc.com (key code J421Z). Or you can mail or fax the order form enclosed with you Back UPS Pro 350U or 500U."
Back-UPS is detected as an ""Unknown Device"" in Device Manger
Product Line:
All APC Back-UPS UPS utilizing USB communications.
Environment:
All APC Back-UPS UPS utilizing USB communications.
Cause:
If communication between the PC and the USB compatible Back-UPS, is not working properly when the cable is first connected, an ""Unknown Device"" is detected. This problem may be the result of a weak USB receiver on the PC side. If the UPS itself is not detected when the cable is connected (i.e., its not detecting a ""Back UPS Pro 350"", the installation of APC's Power Management Extensions or Powerchute Personal Edition may fail or hang after the setup.exe file is executed.
Resolution:
1. Make sure the UPS and PC are turned on. Disconnect and reconnect the USB cable a few times until the PC detects the appropriate UPS model. Once it
does, continue on with the installation instructions. If this is not successful, go to the next step.
2. Check to see if the Human Interface Device (HID) drivers are already installed. If they are not installed, the Add New Hardware Wizard will not start
up when the USB cable is connected. If the HID drivers are installed, then continue on with the installation of APC's Power Management Extensions
software. To check to see if these drivers are installed go to Device Manager (Start - Settings - Control Panel - System - Device Manager) and look for a
device category called ""Human Interface Device"". If you then unplug the USB cable, this line item will disappear. When you reconnect the cable, the
category will reappear. This confirms that the drivers are properly installed.
3. Confirm that your PC's USB ports are enabled. Go to Device Manager (Start - Settings - Control Panel - System - Device Manager) and look at the list of installed devices.
Towards the bottom, you should see, ""Universal Serial Bus controllers"" and within that you will see, XXX ""Universal Host Controller"" and ""USB Root Hub"".
If Device Manager does not list these items, then your PC is not properly configured to support USB ports. Consult your PC manufacturer for help on this issue.
4. If you are connected through a USB Hub, try connecting the supplied UPS's USB cable directly to a USB port on the PC itself.
5. If other USB devices are connected, try removing those other devices before connecting our USB cable.
6. If possible, try the same installation on another PC or with another UPS.
7. Reboot your PC. After reboot, did your PC recognize the UPS or are you still receiving the initial message of ""Please check that the USB cable between your battery backup and PC is properly connected”? If so, there are a few parameters of your PC’s BIOS that need to be changed in order for your PC to recognize the USB device as an APC UPS after each boot. These changes are as follows:
Advanced Power Management – Needs to be disabled
USB Legacy Device – Needs to be enabled
Note: An APC representative cannot make changes or assist customers in making changes to the BIOS, as it is a liability to APC. The BIOS of your PC is both manufacturer and model specific. Consultation of the Original Equipment Manufacturer is advised in making these changes.
8. If none of the above steps work, please contact APC's Technical Support in the United States and Canada via E-Support at www.apcc/support/contact or via
telephone at 800-800-4272. For support outside of North America, please refer to APC's worldwide contact page at www.apcc.com/contact/#worldwide
Note for Back UPS PRO 350U or 500U users: Compaq Presario Series 5000/5100/5200 computers using non-Intel chip sets have demonstrated unpredictable USB performance with some USB peripherals. APC has developed a special USB connector for these computers which will significantly improve the reliability of USB communications. APC strongly recommends the use of this special connector with Compaq 5000/5100/5200 series computers.
To get your special USB connector shipped to you at no charge, visit the Web at http://promo.apcc.com (key code J421Z). Or you can mail or fax the order form enclosed with you Back UPS Pro 350U or 500U."